Change SubdirectoryDatestampFormat

I am trying to use assetSubdirectoryDatestampFormat and want to have it in YYYY/YYYY-MM format (without day). Changed
assetSubdirectoryDatestampFormat = “y/y-MM” in ~/Pictures/.photostructure/settings.toml but seeing no new directories in my Library dir ~/Pictures. Fresh PS installation.

What is the proper format here?


Did you choose an empty library or add new pictures to be imported? AFAIK, PhotoStructure does not move already imported pictures.

Thanks. It’s a new library and fresh PS installation.

This is correct. If PhotoStructure finds an asset already in the library directory, it won’t move it into a different directory.

@Const are the files you’re importing outside of ~/Pictures?

@mrm Yes, the files are on NAS mounted share outside of ~/Pictures. They are imported OK, if I leave the assetSubdirectoryDatestampFormat setting commented out, but the directories structure is YYYY/YYYY-MM-DD and this is not what I am trying to achieve.


You’ve had a bunch of problems with settings, sorry about that! I wonder if the settings.toml that you’re editing isn’t the one that PhotoStructure is reading from, or however you’re editing it, results in an invalid config file?

Also: are you removing the comment in front of the default value? You need to remove the # prefix, which is a comment.

This will be ignored, as it’s a comment:

# assetSubdirectoryDatestampFormat = "y/y-MM"

This is correct:

assetSubdirectoryDatestampFormat = "y/y-MM"

If this isn’t the issue, can you email or DM me a file that you’ve edited so I can check?

FWIW, I use VS Code with the “Event Better TOML” extension, it helps making comments (and mistakes) nice and obvious:


For this setting (and all settings), know that you can also use environment variables, which always override any defaults or whatever’s found in your settings.toml files. Setting


should work.

I re-did PS installation again and it works now.

What is the best way to start from scratch, btw? I do “rm -rf” on ~/Pictures, ~/.cache and ~/.config. Anything else needs to be deleted?


The uninstall instructions walk through the directories that PhotoStructure writes to for every supported platform.

Please make sure you don’t inadvertently delete your originals!

…I only need backups when I don’t have them…

I had an issue where I edited the settingsfile in notepad and PS started throwing errors related to not beeing able to read the settings file.

I managed to identify the problem and it was related to encoding. I dont remeber which one but i think it was that notepad changed from or to utf BOM/ w/o BOM. After reverting encoding with notepad++ to the same as the other settings file it worked perfect again.

It might be good if PS either could determine encoding before ingestion or simply retry With/without BOM in case it fails.

Also it would be good if PS recreated the default settings file on startup if it is missing so that you easily could restore defaults by removing the settings file.

Written on mobile, apologies for spelling

Ugh, sorry @hanpq and @Const , I (incorrectly) assumed people’s editors would write UTF-8. Thanks for the reminder about BOMs!

I’ve just added UTF-8-with-BOM and UTF-16 (LE) support for Settings I/O: it’ll be in the next build.

@const, if you can sent me an example settings.toml, I can verify that this was the issue. :+1:

Windows tools adding an UTF-8 BOM to mark Unicode encoded Files is probably the probably the most common and notorious case.

I haven’t yet encountered an editor silently converting UTF-8 to UTF-16.

Sorry about delayed reply, but I already ditched that installation. New one works fine. I don’t know what was wrong with it, but I use vi on U18 to change settings file(s).

1 Like

Do you mean UTF-16? Can you share the relevant bit of your .vimrc so I can try on my box?

What I meant - I just use VI on Ubuntu 16, not Notepad or Notepad++ on Windows. What would be relevant bit in vimrc? I don’t have .vimrc in my ~/, but I have /etc/vim/vimrc file…