Photostructure stuck at processing

Expected Behavior

Folders should be scanned and photos should be imported

Current Behavior

Photos are not imported, importer stuck at scanning.

Steps to Reproduce

  1. Set Library folder on a NFSv4 share
  2. Set source folder on a NFSv4 share
  3. Start sync
  4. Sync gets stuck at processing and will not progress even if there is just one photo in the folder. Step is scanning folder.


Operating system and version:

Using LXC container of Ubuntu 20.04.2 LTS with Proxmox as host

PhotoStructure edition:
PhotoStructure for Node

Howdy, and thanks for trying out PhotoStructure. Sorry about the glitch!

I haven’t tested NFS mounts before: I would be surprised if Alpine is providing lsblk or df output that PhotoStructure didn’t know how to parse. (edit: this isn’t relevant, I see you’re running a VM).

Can you DM me the volumes table from your about page, and if you have time, set PS_LOG_LEVEL=debug, restart the container, wait a minute, and then send me the logs?

Hello, unfortunately it looks like it does not write any sort of log whatsoever. Even with the variable set:
to debug.

I have this line from the systemd startup log:

Apr 25 08:07:58 photostructure[460]: PhotoStructure is ready: <http://localhost:1787/>
Warning: journal has been rotated since unit was started and some journal files were not opened due to insufficient permissions, output may be incomplete.

Unsure where it does not have permission as i’m able to do everything via the user that was set.
I have sent you the requested data via DM.

Edit: I cannot DM you as it looks like, probably i don’t have enough posts. I will put the table here as it’s just a container that is for testing at the moment:


mount size free volume id label
/ 8.4 GB 5.5 GB
/dev 500 KB 500 KB
/mnt/Pictures 5.8 TB 3.1 TB 23Jc7qi9E //

I have made some more changes and directly in the home folder i have created a folder with like 5 photos and a separate library folder. By the looks of it, it still is not scanning and/or adding any photos to the library. The logs situation is the same, it does not write logs.

Do you have the volume bind mounts set up? (ah, I see it’s a VM)…

I updated your user level, you should be able to dm me now.

If environment variables aren’t working, what renders to stdout if you run ./ --verbose?

I have run the app with --verbose

I hope it’s fine that i’ve included it in a pastebin as it’s quite lenghty.

Edit: I have sent via PM the Paste as it does contain some info i would not like displayed here.

So today I checked if those photos were imported and they were not, deleted the whole thing and went with a fresh new installation, unfortunately Photostructure is still not importing anything :frowning:

I’ll look at your logs today after I caffeinate.

Awesome :grin:, if needed i could do a remote session thingy if you want see for yourself

For anyone else following along: PhotoStructure refuses to run the sync process if there isn’t sufficient disk free on the library drive, which meant his library was empty.

I need to make this more obvious on the home page!

Coming back to this issue, it was solved by modifying a settings in the settings.toml file.


PhotoStructure will pause processing if the GB free on the disk that your

library is stored on drops below this value. The value provided here will be

multiplied by 1000^3. Note that many OSes will corrupt themselves when disks

fill up, and SSDs can fail as they approach full capacity. A value of less

than 8 may be unsafe (due to hibernation and os update files).


However now it not found in the settings file so i just added it and it’s not recognised :frowning:
Is there any way of resolving this now? I tried to turn off healthchecks however that did nothing visible in this case.

Posting a photo for reference too.

Settings can be a bit challenging: there are actually two settings.toml files.

Also, if it’s more convenient for your setup, you can also use environment variables.

In any event, filling the root partition can cause havoc, especially during system upgrades or when an app gobbled ram and it went into swap. I’ve personally had to reinstall or recover macOS, Windows, and Ubuntu, all due to upgrades that were unwittingly applied when my root volume was full.

Rather than configuring PhotoStructure to run with less free disk, can you free up any space on /?

I have increased the space just now, the total space available on the root system is 14GB, i prefered not to, but i’d rather not fight it at this points :smile:

I have strict control over the space as these are containers on proxmox so i have control over what happens and even if it decides to do something odd i don’t have to worry about it, just fix it whenever as just that container is gonna crash. This is why i prefered just not giving that much space to begin with.

Ah: in that case, the next build will support setting minDiskFreeGb to 0, and completely disable this check. :+1: