Videos do not appear in the interface after syncing

Hi there,

First up, PhotoStructure is such a great piece of software, thanks for creating it!

I’m having an issue getting videos to appear within PhotoStrucure. Syncing displays all the images as expected, but skips any kind of video I add to the path. I’ve tried a bunch of things suggested on the forums to troubleshoot but I’m still coming up empty unfortunately.


  • I’m on MacOS 10.15.7
  • Tried both PhotoStructure for Desktop and PhotoStructure for Node versions (1.1.0)
  • About PhotoStructure shows that I have FFmpeg 5.0.1.

What I’ve tried

  • I’ve tried MOV and MP4 files, newly created ones via ffmpeg to be sure there are no errors in them.
  • I’ve used .photostructure info on Node and I can’t see a reason why they would be excluded as they all show errors: [] rejected: [] ignoredBecause: []
  • These files don’t require transcoding by default, but either forcing it on or off using settings does not change anything.

What I think it might be

  • On this forum post it was mentioned to test ffmpeg’s arguments, and when I do I get an error with “singlejpeg” not being a valid output format. After digging through debug logs, I can see the following:
{"ts":1654851263136,"l":"warn","ctx":"sharpReadable(/path/to/video/FILENAME.MOV)","msg":"strategy failed for extractVideoFrame: Error: [NULL @ 0x7febb00060c0] Requested output format 'singlejpeg' is not a suitable output format\n/Users/user/Library/Caches/PhotoStructure/imgcache/2v/sg/rj1pppzzkzq7v0g8exg6/.frame.jpg: Invalid argument⁶⁷"}
{"ts":1654851263137,"l":"warn","ctx":"AssetPreviewBuilder(1)","msg":"Failed to set shown file to AssetFile(1)","meta":"Error: Cannot read /path/to/video/FILENAME.MOV (video/quicktime): [NULL @ 0x7febb00060c0] Requested output format 'singlejpeg' is not a suitable output format\n/Users/user/Library/Caches/PhotoStructure/imgcache/2v/sg/rj1pppzzkzq7v0g8exg6/.…"}
{"ts":1654851263139,"l":"warn","ctx":"AssetPreviewBuilder(1)","msg":"none of the files are valid"}
{"ts":1654851263139,"l":"warn","ctx":"UpdateAsset(1)","msg":"Failed to update previews. Un-showing asset 1","meta":{"cause":{}}}

So as of a few hours in troubleshooting, this seems like the likely issue, although I’m not entirely sure at this point. I can provide full logs, just not sure what would be helpful. If you have any thoughts on how I might fix this issue it would be most appreciated! :pray:

Welcome to PhotoStructure, @Red, apologies for this glitch!

I’ve fixed the issue with singlejpeg In V2.1, which is currently in alpha, so there are a couple other, new bugs I’m still banging on, but it may be better for you. Details are here:

Thanks for getting back to me so quickly @mrm :slight_smile:

Ah ok, awesome, already fixed! I can’t get the macos desktop app to launch (just hangs on the splash screen), so there are probably some things you’re working through there. The Node version works however, and all videos now appear in the library correctly, so I’ll stick with that one at this point.

I’ll leave any further playing around until it’s out of alpha at least! :joy: Thanks again.

Crap, that’s no good. The macOS desktop app should work on Monterey with either intel or apple silicon hardware (but you need to install the correct version, of course).

What version of macOS are you running, and on what hardware?

It’s a mac mini running Catalina (10.15.7). My home ‘server’ is powerful enough, but certainly not brand-new, so it won’t run the latest macOS. I assume using older hardware is probably not uncommon for these kinds of applications.

Having said that, I’ve tried the desktop app on my main machine (Monterey, 12.4, Intel core) and it also doesn’t get past the splash screen… Please yell if I can provide any logs that would be helpful :+1:

Unfortunately, Apple doesn’t prioritize backwards compatibility. I had to bump up the supported version of macOS in v2.1 to Monterey to get my apple silicon native build to work.

Logs would be great, though, maybe it’s something easy I can work around.