1.1.0 docker: two different dates appearing in the same date header


In this same group of images, I can mouse over and see pictures from August 1st as well as August 31st!

Upper left picture’s mouse-over:

That picture’s info:

Lower left picture’s mouse-over:

That picture’s info:

I suspect I’m missing something here, but this URL show show all assets from the month of August 2022.

Did you change the tagYMD setting to be ymd?

Maybe I’m explaining poorly; thank you for helping me clarify. The URL is intended to show the month of august 2022. Which it does. However under the When / 2022 / Aug / 1 heading, I can see pictures from both august 1st and august 31st.

I’ve found this in one other instance too, in July. Maybe there are more; I didn’t persue it further.

The tagYMD setting is still commented out in <library_path>/.photostructure/settings.toml

Where are you seeing these headings? I see no headings when I navigate to (let’s say) https:///tag/When/2021/9?seed=59999 - it’s just one big list.

I believe you guys are on different versions: I’ve changed the header from v1.1 to v2.

I initiated a full library rebuild 2 days ago. It has 2-3 more days to go. I found in the library settings.toml a flaw in the config entry:

assetSubdirectoryDatestampFormat = "y/MM/dd

Notice the missing closing quotations!. Who knows what kind of mess that was causing. Maybe this, too.

Errors like this will cause the library settings.toml file to be ignored.

I’ve just added a healthcheck for reading settings now, to make sure this is easy to diagnose in the future:

If ps ignores that file when it’s invalid, what would cause it to continue honoring the ymd configuration?

New photos added since that mistake are still correctly nested in yyyy/MM/dd/filename.* rather than the default yyyy/yyyy-MM-dd/filename.*

From my testing, it seems that a .toml file is either wholly imported or rejected — but remember there are three sources for settings: the environment, system settings, and library settings — so perhaps the path was set in another file?

If not, can you send me your settings.toml so I can see what’s going on?

Turns out… I had set the env var for this setting in my docker compose file to ensure I wouldn’t have to worry about it and rebuild my library again (which takes about 8 days). I did that long enough ago that I’d forgotten about it entirely!

I still sent you my heap of settings stuff anyway in case there was any other things you might have been curious about.