23.8.0-prealpha.2 first startup issue


I got this error when upgrading to prealpha.2 today. I’m using the docker version of photostructure.

ERR_DLOPEN_FAILED: SQLite cannot directly write to the library or the cacheDir.: The module ‘/opt/photostructure/node_modules/better-sqlite3/build/Release/better_sqlite3.node’: was compiled against a different Node.js version using: NODE_MODULE_VERSION 115. This version of Node.js requires: NODE_MODULE_VERSION 108. Please try re-comp…the module (for instance, using npm rebuild or npm install).

This was fixed in prealpha.3

Ah ok, I got prealpha.2 on the :alpha tag however the subsequent releases seem to be published to the prealpha tag only.

This did indeed resolve itself when I jumped up to prealpha.5

yes, it was a mistake that the :alpha tag was updated at all. @mrm did not intend for that to happen at all. Not sure what he’s doing to revert the :alpha tag back

Apologies for the misconfiguration that meant :alpha got the prealpha build. I’ll push v2.1.0-alpha.7 back to :alpha (see below), but I hope a v23.8 build will be :alpha-worthy soon.

@hanp thanks for reporting this.

I haven’t ever force-pushed a previous docker build before–and if I simply rebuild from the prior Dockerfile, unfortunately, the base-tools image wasn’t pinned to a version, so it won’t be the same as the prior image.

Do you (or anyone) know how to pull down a given image and push it back with a different label? (My google-fu for this task failed me)

Until this is fixed, you can pin to photostructure/server:v2.1.0-alpha.7 instead of photostructure/server:alpha.

Is this at all helpful?

derp, I think that’s local only (not the repository). Sorry!!

Thanks @tkohhh , this worked!

$ docker pull photostructure/server:v2.1.0-alpha.7
$ docker tag photostructure/server:v2.1.0-alpha.7 photostructure/server:alpha
$ docker push photostructure/server:alpha

(I didn’t know the tag op could take two args!)


$ docker buildx prune --all --force ; docker system prune --all --force
$ docker pull photostructure/server:alpha
$ docker run photostructure/server:alpha --version
1 Like

Oh awesome! I convinced myself that it wasn’t the solution, so I’m extra glad that it worked!