4k video not playing properly

Expected Behavior

Clicking on a video recorded in 4k / 60fps will play it properly.

Current Behavior

The audio plays appropriately, but no video is shown.

Steps to Reproduce

  1. Attempt to play a video recorded in 4k / 60fps

I checked various files filmed at different frame rates, and everything in 1920x1080 plays fine regardless of FPS (30/60/120/240 all checked).

Environment

Operating system and version: Windows 10 21H1 (19043.1052)

PhotoStructure edition: PhotoStructure for Desktop 1.0.0-beta.12 with VLC 3.0.16

Can you email me an example video? I suspect the encoder isn’t something chromium can decode natively.

You can also try opening Chrome, Firefox or Edge to http://localhost:1787 and see if the video still had rendering issues.

I tried Chrome and Edge on Windows as well as Chrome and Safari on Mac - all the same result.

Emailing over a sample video now.

Thanks for sharing!

I suspected that the issue was due to PhotoStructure not thinking the video needed to be transcoded, but that’s not it:

$ ./photostructure info /Downloads/IMG_2676.MOV --filter needsTranscoding --filter mimetype

[
  {
    nativePath: '/home/mrm/Downloads/IMG_2676.MOV',
    needsTranscoding: true,
    mimetype: 'video/quicktime'
  }
]

I’ll have to dig a bit more.

If there’s anything else I can provide that would help, let me know!

I’ll try to reproduce the issue locally: if I can’t, I’ll email you directly.

Thanks again for the report!

I’ve been away for a bit and wanted to check back on this. I actually went into the previews folder and found that the preview videos themselves are the problem. When I try and play one I get a black screen, but the audio is there. The good part is that it means PhotoStructure is playing the video properly. However, it definitely seems like something is going wonky with the transcoding of the preview from a 4k video source (specifically iPhone).

Edit: I was finally able to do some additional troubleshooting as I was planning on wiping my library anyway. I moved over a few 4k files from my iPhone and set the library to not transcode, and had some interesting results. On Windows, Chrome would only play audio, and Edge would play audio and video, but the video was choppy. On Mac, Chrome only plays audio only, and Safari plays flawlessly. On iOS, Safari plays flawlessly. And, none of the videos play in the PhotoStructure app.

With the native 4k stream, Safari is clearly handling the videos no problem, but everything else kind of chokes. Is Apple doing something that weird with their iPhone files that it impacts playback and transcoding?