Exclude Videos


I need to exclude Videos form syncing / transcoding since I suspect that some videos are corrupt and therefore the sync process hangs. I can’t get pass a few photos / videos to be important:

Shouldn’t I be able to stop trancoding video with this label: PS_TRANSCODE_VIDEOS=false

Environment variable, not label, but yes.

ahhh yes of course sorry my fault!

Right, and it should! In case you missed it, here is the documentation for that setting:

What may be confusing, though, is that transcoding is different than importing.

If a video is already encoded as a “standard” MP4 (or matches the doNotTranscodeAudioCodecs and doNotTranscodeMimetypes filters), it isn’t transcoded. This is handy if you know that the browsers that you’re going to use to access your library can natively handle specific video formats.

But I buried the lede.

PhotoStructure doesn’t currently have an explicit “don’t import videos” boolean setting.

PhotoStructure won’t import videos if you don’t have VLC or FFmpeg installed, but if you’re using the docker image, ffmpeg is always there, and I shouldn’t require you to uninstall an app if you’re using the desktop version.

You can effectively filter out all videos by setting these environment variables:


but these are hacks. I’ll add a proper setting in the next build, but until then, It’s what I recommend for now.

(if you’re interested, I will add a an “excludedMimetypes” string array setting (which you will set to ["video/*"]).

thx a lot but currently I just use this setting for testing. I have a library with ~80’000 images and videos. and the last ~1200 images / videos don’t get imported and I’m not sure why. I have a lot of *.mts Video files from a old sony camera and they get converted but afterwards the Color is very strange and not viewable. So maybe ffmpeg struggles with longer *.mts videos, I’m not sure.

I just realized it’s only a problem if the converted video is shown in the browser. When I directly open the video in Media Player Classic / VLC it looks fine:

Me again. The problem appears only in the Brave browser when I have Hardware Acceleration switched ON. Playing the same clip in Firefox or with Hardware Acceleration OFF it works…

The crazy neon videos will be fixed in the next version: details here: