File Sync Issue

I have an odd problem that I just can’t get to the bottom of. I have a directory with three photos of recipes in it. Two of those photos are not detected by the sync process and are not imported into my library. One of the photos imports just fine. I can’t work out why the two photos won’t sync.

I’m running Photostructure using the official docker container on Unraid (6.12.6) & Photostructure (2.1.0-alpha.7). I’ve checked user, groups and permissions across all three files both from a root term in Unraid and from a term in the docker container itself. All the files have identical details:

/ps/app # cd /mnt/to-import-photos/Photos/Original\ Size/Recipes/
/mnt/to-import-photos/Photos/Original Size/Recipes # ls -al
total 5876
drwxrwxrwx 1 node users     100 Dec  8 09:14  .
drwxrwxrwx 1 node users    4096 Nov 30 10:21  ..
-rw-rw-rw- 1 node users  854824 Nov 22  2019 'Apricot stuffing (2).jpg'
-rw-rw-rw- 1 node users 2384558 Feb  4  2018  Sauerkraut1.JPG
-rw-rw-rw- 1 node users 2767604 Feb  4  2018  Sauerkraut2.JPG

I was running stable but updated to the beta branch in order to get access to the Sync Report CSV. Looking at the CSV I can see that the files are not detected by the sync process, there’s no entry for them at all.

As a long-shot I also ran dupeGuru to check there are no duplicates of the photos anywhere in my library. There are not.

Any idea what’s happening here?

Have you seen this page?

Now that you have CSV logs, you should be able to search those files for the missing file name and see what it says.

Let us know what you find!

Yep. That’s why I tried some of the things mentioned above. I was seeing the issue in both PhotoPrism and PhotoStructure (I installed both last week while trying to get to the bottom of the issue).

For some reason, the two files have just synced OK in PhotoStructure. Still not showing up in PhotoPrism. It’s the strangest thing.

Clearly the issue is resolved now (at least for PhotoStructure) but if anyone knows why this might have happened I’d love to know.

What did the sync report say?

The second-easiest way to see what’s going on for a given file is to use the info command-line tool:

There will be several fields you want to check out there, but whyRejected should say exactly what’s going on.

I’d also suggest pulling in a v2023.11 or v2023.12 build, currently available via the :alpha update channel.

The third and final way is to run sync “by-hand” and tell PhotoStructure to just import one of those files, with debug logging:

photostructure sync --debug /path/to/file | less

The issue with this approach is that debug logs are verbose, and pretty hard to wade through. I’d use less to search for warn_ and error_, which may provide a clue as to what’s amiss.

Still stuck? DM me a zipfile with those files and I can take a look.

Thanks. Initially the sync report didn’t have the files in at all…it was like they weren’t even being detected in the directory. The files have showed up now.