First import - NFS files unexpected missing asset file id

Hello,

I am trying an initial import of my photo library mounted over NFS but can’t seem to get anything to import. I realized the issue around uuid files and fixed that but still no luck.

Here is the error that keeps popping up as I tail the logs:

2022-10-02T02:27:11.056Z sync-file-1194 error AssetFileImporter(/mnt/photos/…) _apply(): unexpected missing asset file id { path: '/mnt/photos/

Any ideas where I should start looking first?

Thanks!

Cancel that - just fixed it. So after fixing the UUID issue, I just deleted the entire .photostructure database folder and started from scratch. Now photos are importing properly.

Welcome to PhotoStructure, @dcela , apologies things didn’t just work right out of the box for you!

Read-only NFS mounts should work. PhotoStructure should see that it can’t extract a UUID from that mountpoint, and resort to a psnet: URI for those files.

The issue with psnet: paths are that they rely on a stable host name and share name. There are a couple swings I take to try to normalize the hostname if it changes (like asking the local named to round-trip to IP address and back to hostname), but I suspect most people’s networks don’t have reverse DNS records.

If you have the time, can you DM me the result of grep nfs /proc/mounts so I can try to see what went sideways? Please XXX out any credentials.

OK–please ping me or pop into Discord if you see anything else amiss!

Cheers :beers: