How to configure the URL on Headless Server

@mrm , Now that the docker image is running, I see the localhost url assigned. When i attempt to access this URL via laptop using my NAS server name (“DEB-NAS-FUN”) as http://deb-nas-fun:1787; I receive a unable to connect error. Also tried using the internal IP address.

Screenshot of the log showing docker running successfully on port 1787:

Question: How do i configure the headless server to allow access to the URL? Where would i make those changes so it’s routable?

thank you!

@mrm , becuase i see other mentions of it…i want to show that my exposenetworkwithoutauth = true:

I’m not currently setting the aforementioned withoutAuth value. Have you tried the IP address:port instead of the name of your Synology?

I’m able to hit my instance at that, and then I forward the IP:port externally with Traefik.

Edit: Missed the part where you tried the IP address. Can you confirm the port is part of the docker container mapping?

Hi @adamf ! Thx for quick reply. I can confirm the port is part of docker container mapping as long a you are ok with a screenshot of it via the docker mgmt GUI? If you want me to confirm using a different method, pls just post instructions. Here is the GUI screenshot:

Please disregard. @mrm & @adamf . I figured it out. I need to use the mapped local port of 49205. Working now =)

Nice find. That said, you can remap the local port if you’d like, but as long as it works!

1 Like

Excellent: if you need instructions on setting up a reverse proxy, this page might help: