How to restart your library from scratch

PhotoStructure uses a bunch of techniques to keep your library intact and valid, but unfortunately, power outages, software bugs, disk errors, and network errors can all take a toll on the integrity of a library.

PhotoStructure runs some validation on library databases on startup, and if those fail, it will ask you to try to recover from a library database backup.

If none of the backups work, you’ll want to restart your library from scratch.

  1. Make sure PhotoStructure is shut down

  2. Follow these uninstallation instructions (there are different sections on that page for every supported platform).

  3. Restart PhotoStructure.

Know that you’ll have to wait for PhotoStructure to rebuild your entire library, so this may take a while (even days, for very large libraries!)

If you have any questions or issues, please reply to this topic or ask on discord: we’ll get things sorted!

Are you sure you don’t also need to clean out /ps/tmp?

It seemed in my issue I had to… but maybe it was something weird in my setup.

Ah, good point, is forgot about the replica DB. V2.0 adds a file sanity check to make sure an older library copy isn’t used as a replica, but to be safe, you can delete /ps/tmp.

Sorry to reactivate this thread but I’ve rediscovered PhotoStructure and am having trouble restarting from scratch.

I’ve tried reinstalling the v1.1.0 and also deleted Photostructure in Appdata Local and Roaming.

However when I try creating a new small library, it seems to get stuck on processing.

Can you tell me where I can find /ps/tmp (is the parent directory root?) or is there anything else I need to delete for a completely clean build?


Howdy, @Wanderweger !

Sorry to hear that sync is getting stuck: I just updated my instructions in the top post, hopefully those will be easier to follow.

If that still doesn’t fix things, please send me logs and I’ll take a look.