Image corruption on import

Expected Behavior

Images from camera to import/thumbnail correctly/visibly

Current Behavior

Majority of images are coming into the system visibly corrupted

Steps to Reproduce

  1. Launch Photostructure docker on UnRaid
  2. Import starts
  3. Look at thumbnails


Operating system and version: UnRaid 6.9.2

PhotoStructure edition: PhotoStructure for Docker beta 14

Welcome to PhotoStructure, @craigcook , and apologies for the crappy less than stellar first impression!

Can you email or dm me an original image so I can try to reproduce locally?

All good. I’m with you for the long run if this solves my mess of photo storage over the years :wink:

Will send you a link as these images were when I was going through my RAW phase so .NEF and not small.

Thanks for sharing that example!

I just tried importing that NEF and it rendered correctly on my ubuntu box using PhotoStructure for Node

what edition of PhotoStructure are you using? (ah, I see you’re on docker/unraid: I’ll try that now).

What OS and browser are you using, btw?

I’ve tried both Windows 10 and MacOS Big Sur w/ latest Chrome.

Same problem on both.

Only thing I can think of, Photostructure stopped running on Unraid after initial start (renders seemed to be ok?) With zero thumbnails after restart, I kicked off rebuild library - saw odd image rendering above then.

I believe I have debug logging turned on if that helps and you want a file.

Of note: it looks like some NEFs are loading correctly (just checked a random sample) - there are a lot that are not as seen in the attached initial image.

In trying to resolve this:

Environment: Unraid

I deleted my PS docker image (was using the :beta tag before v1.0)
I re-downloaded the PS docker image leaving all defaults exact for PS library, PS Backup, Pictures locations
I launched the docker container in Unraid
New start up, recognized my account as Plus subscriber
Clicked start
Clicked rebuild

Mini thumbnails in rebuild process showing same issue.

Unraid system information if helpful:

M/B: Intel Corporation DQ77MK Version AAG39642-400 - s/n: BTMK22401MWZ

BIOS: Intel Corp. Version MKQ7710H.86A.0074.2018.1025.1727. Dated: 10/25/2018

CPU: Intel® Core™ i7-3770 CPU @ 3.40GHz

HVM: Enabled

IOMMU: Enabled

Cache: 1 MB, 256 KiB, 8 MB

Memory: 32 GiB DDR3 (max. installable capacity 32 GiB)

Network: bond0: fault-tolerance (active-backup), mtu 1500
eth0: 1000 Mbps, full duplex, mtu 1500
eth1: 1000 Mbps, full duplex, mtu 1500

Kernel: Linux 5.10.28-Unraid x86_64

OpenSSL: 1.1.1j

Let me know if there are logs I need to look at to help debug this or if I didn’t blow this away correctly to begin a clean test.

I’m also happy to do manual import/conversions on a known trouble image file on my system to help isolate the potential problem.

I see that library rebuilding doesn’t redo the import process:
Library rebuilding happens in several steps:

  1. File metadata is updated.
  2. Assets are regrouped.
  3. Asset previews are refreshed.
  4. New taggers may be applied.

To nuke/rebuild to I just need to delete the PS library that has been built up?

Apologies that this issue still hasn’t been resolved for you!

The bit that you care about is “refreshing the asset previews”, which is a step that happens both in sync and rebuilds, but only if the file is missing or the dimensions are incorrect (they can’t detect the wonky color map issue).

Regenerating previews can actually be “forced” by either visiting the asset in the UI and then clicking “sync this asset”, or “manually” on the command line using the forceRebuildPreviews setting.

Both “rebuild” and “sync” do a quick check to see that the preview images are there whenever they “visit” an asset.

If you want to completely restart:

  1. Shut down PhotoStructure
  2. Delete the .photostructure directory in your PhotoStructure library. This directory contains you library database and preview images.
  3. Restart PhotoStructure. It will walk you through the settings page again. You can keep the prior library location.
  4. Wait for the initial import to compete.
1 Like

Can I do this for a specific asset on the command line? This will help me localize the process and help determine where the potential error is.

Update on this: I rebuilt the entire library and the raw/nef images that have the colour mapping issue are still there. These images render correctly when opening up the NEF files on a macos laptop or sent as a link (w/ thumbnail preview) in drop box. Is it a possible codec issue in the docker container? I haven’t modified anything on the template other than image asset mount points.

Sorry for the latency: I’ll get back to you tomorrow.