Import hangs on last few 300 images

I installed Photostructure (alpha V2023.12.0-alpha) on OpenMediavault by Docker Compose. No problems. After testing I tried to import my 50,000 images or so. All went well, until the last 366 images. Rebuilding the library gave the same results. The third time it first hangs on 405 images to do, an a day later on the well-known 366.
So I think that there are some format errors in my input files. My question: is there a possibility to see the last imported files, so I can inspect / delete the culprit(s)? I tried to use the CLI tools, but that created no files with which comm could work. So it is not clear which files are imported.

Ugh, sorry you hit this snag! This is exactly the sort of situation I built the sync reports for–the last couple lines in the last CSV should be enlightening.

If there’s a file that consistently wedges the sync, and it doesn’t contain any private content, please zip it up and DM or email it to me so I can see what’s going on.

But I don’t see the option to activate sync logs in the docker version?

Sync logs by default are stored in your mapped library path: [mapped path root]/library/.photostructure/sync-reports

I’ve been trying for days to import my library and it crashes with this message:

“Health checks failed. Click for details.”

Then it restarts and says 3 days left…

@Cirion ,
Could you start a new thread for this? I don’t want to step on @gijsh 's issue.

I am sorry, in my case there are only the normal logs at .photostructure/logs, containing endless warnings about timeouts.

I would like to have the opportunity to set the sync logs on, like in te desktop and node version.

I don’t know if there’s a way to disable the sync reports, so maybe there’s something wrong. @mrm will need to comment on this one!

Using the Docker alpha version (2023-12). The sync-log files are being built up during resync, but they disappear after some time, before the sync hangs or is closed (?).

Having no log files to guide me, I chose a piecemeal approach to build up my library: adding (large) directories one at a time, after a backup of the former library version. During this process, I discovered some problems with (the right version of) ffmpeg. After installing the latest version from their site (not the apt/.deb version) , things went relatively well. I just had tot remove some old input files which caused the hanging of the sync/rebuilding process. Sometimes there were a lot of health check errors - I cannot tell why.

In this way, I imported about 55,000 photos and 500 videos. So things are going well, but I still think that it is useful to screen the input files for non-graphical files like json, rss, jap etc put there by photo programs like Jalbum. To often, these directories seemed to disturb the sync process.

It costs a lot of extra time, but at least I know more or less what I am doing.
All’s well that ends well …

And again after I added about 2000 images / videos sync hangs on 4 minutes:

I use 2023.12.0-alpha.7 Looks like syncing is (like always) very slow:

Further:

  • restarting sync was not automatically: does the scan work?
  • Maybe there are some corrupted images, but I don’t know how to find them. There is no sync log on the server, nor the possibility to start them from the menu.
    What can I do other than rebuilding the library?

I’m not sure if you saw, but there is a new version available: v2024.3.1-prealpha

Release notes: PhotoStructure | 2024 PhotoStructure release notes

If you haven’t already, you should probably move to the new version as there was lots of work done on the sync process. Note that it is still an alpha and there are some bugs. Still, those of us running on Docker have found it to be a nice upgrade and reasonably stable.

As always, make sure you have backups!

Thank you for the hint. I installed the prealpha version and indeed, rebuilding and sync go better now. I am still very content about the quality of the program.

There is something strange on the about page - the end of the library rebuilding is earlier than the start ?

Or is the resync simply stuck?
Sync reports are there, and they give a lot of messages like
‘1710626608932,2024-03-16T22:03:28.932Z,/ps/library/2017/2017-10-30/6388_IMG-20171030-WA0010_1000x563.jpg,failed,syncFile,stuck after 301063ms,’ like this:

Maybe these messages refer to corrupted files? Anyway, the library rebuild seems to have come to a standstill. In the webviewer everything seems OK.

I am waiting for the program to resume automatically resync ing the library and/or input dir.

Howdy! I’d have to look at debug logs to see what’s causing those files to not get processed in a reasonable amount of time.

If you set log level to debug and send me your worker and sync logs, there may be something in there that tells me what’s amiss.

Here are the logs, including a graph of the CPU utilization at the same moment.

Thanks for sharing–I was able to fetch the archive.

In the interests of privacy I removed the link to your logs just now (and you can remove it from your nextcloud instance to save disk).

Be sure to pull the latest beta build–there are a couple additional updates to avoid “stuck” syncs.

Yesterday a 'spontaneous recovery’of the library happened. Looking closer, the new prealpha version was installed (watchtower). :ok_hand:
Also, after installation of the new beta everything was OK again. So it seems that the sync problems were solved. Thank you very much.

1 Like