Library not rebuilding

Expected Behavior

After updating from 0.9.1 to 1.0.0-beta 5 PhotoStructure rebuilds the library at a decent speed

Current Behavior

Rebuild is not progressing. Here is a screenshot at 1040 UK time today (9th June):

image
At this point CPU usage by PhotoStructure was 0.5%

Here is a screenshot at 1101 UK time:

image
CPU usage by PS was 0.1% here.

Overall system CPU usage was below 20% in both cases, so this isn’t about PS being crowded out by other processes. I have restarted PS and this still happens.

Steps to Reproduce

Hard for me to test this as it involves an update from 0.9.1 to 1.0.0-beta 5, but all I did was:

Update from 0.9.1 to 1.0.0-beta 4

The rebuild made pretty much no progress

I then on one of my attempts to restart PS was told 1.0.0-beta 5 was available. I installed this and started. No progress. Restarted PS. Still no progress in rebuild.

Environment

Operating system and version: Win 10 20H2

PhotoStructure edition: PhotoStructure for Desktop 1.0.0-beta 5

Update at 13:07 UK time:

Despite a full system restart and relaunch of PS, it’s only moved to 111,125 remain. That is it’s done 70 photos in more than two hours.

Sorry about the hassle! Can you

  1. Shutdown PhotoStructure,

  2. Set PS_LOG_LEVEL=debug

  3. Restart, let it run for a couple minutes

  4. Then send me those logfiles?

Details here:

I won’t be able to check on them until next week, though:

Logs sent by e-mail! Thanks!

I’ve just upgraded (well, about 1.5 hours ago) to 1.0.0-beta7

It has trivially advanced - it might be slightly faster, but if it is it’s very slightly faster.

image

Update: 30 mins later we are on 110,943 remain, so six photos in 30 mins. Something is up - has upgrading from 0.9.1 to 1.0.0betas corrupted something? If so happy to try and fix.

Cheers!

I also started a rebuild after upgrade from beta.5->beta.7. It seemed to not really be progressing at all after a few were done.

I re-started the rebuild and its chewing along great now.

Not sure what happened, but just mention it for the “you might try again” purposes :slight_smile:

It certainly shouldn’t: I have several test libraries that have migrated to v1.0.0-beta.X from Ye Olde Version ~0.4ish.

Beta.8 will throttle some database maintenance tasks that may have been causing issues, and may fix issues with re-syncing already-in-sync files.

I’m afraid it’s happening again! The first stage of the library rebuild was way faster with beta9 (the stage where it checks metadata I think), but now we’re on “Refreshing assets and previews” and it’s very slow and using very little CPU or disk resource. Here’s a ten minute interval:


2021-06-19 1750 BST

System usage at that time:
image


2021-06-19 1802 BST

System usage at that time:
image

So ~200 images in 12 minutes (3.9 seconds per image) which doesn’t sound that bad, but then why is it being so slow - in both cases PS is using almost no CPU time and you can see the system overall isn’t being taxed. These readings have both been taken after I restarted the machine; I’d left it on overnight and for most of today, and came back to find surprisingly little progress

At this speed left on all the time it’ll take 4.6 days to complete this stage of the rebuild, which is fine if that’s what it needed, but feels like it’s a result of PS being unduly polite about using system resources.

That looks like sync is stuck: can you send me debug logs?

Done - sent via e-mail!

I think I may have had the same issue… chewed along until “Refreshing assets and previews” and then it drug to a stop. I tried doing a “restart sync” and it seems to run through really quick, but I’m not really sure if it’s completing or not - not sure how to tell.

A “status screen” might be something to consider for those not really versed in digging into logs, etc.

Absolutely. I set up the Progress and Operations tables specifically for a status screen, but I haven’t built it out yet.