Make PS_EXPOSE_NETWORK_WITHOUT_AUTH option more visible


I’m very excited about photostructure and have been spending this afternoon setting it up. I had a lot of trouble trying to reach the docker container from another host, and eventually found out that I had to set the PS_EXPOSE_NETWORK_WITHOUT_AUTH environment variable. It took me quite a bit of googling to get to that point though - so can I suggest adding a note about it to PhotoStructure | PhotoStructure for Docker, so it’s more visible for future users?


Sure, thanks for the suggestion!

This article has some more details about this issue:

The article says this setting is enabled by default with Photostructure for Docker. So not sure why the parent had to set it explicitly. I have not had that problem with my docker install.

Agreed, that value defaults to true when running on docker. I’m not sure sure why their port wasn’t exposed.