Not all photos are copied into library

I manually set a path to import from and let photostructure do the organization.
But photostructure only copied a few of the files in the import path into the library directory, although all files from import path are accessible through photostructure, they are just not copied into the library directory.

Any idea whats wrong?


A beta user had this problem too: and it turned out that they were using Docker, and hadn’t set up their /ps/library bind mount correctly. Details are here:

If there isn’t a bind mount for /ps/library, PhotoStructure will copy your photos and videos into your container, which doesn’t show up on your host machine.

If you aren’t using Docker, and/or this doesn’t seem to be the issue, please add your OS, what variant of PhotoStructure you’re using (Desktop, Node, or Docker) (the About page will collect all this information for you).


I should have mentioned some more information in my post.
I’m usind the Desktop version on a recent Windows 10 Pro.

As this is currently a test installation, the library and also the import path are located on the same drive.

Ah, OK:

So, PhotoStructure won’t copy images into subdirectories if they are already in your library directory (I did that so if you’ve got some files already in directories, say, suffixed with an album name, like, 2020\2020-12-27 Morning trip to the kitchen, PhotoStructure won’t undo that organizational work.

More details here:

If your library and your scan path are different hierarchies, (like C:\PhotoStructure and C:\Photos), then that’s a different issue. This article discusses why they might not be importing at all:

Thats the case, same drive, but different folder structures.
I already read the article before posting here, but as far as I understand, this article applies to the issue, that certain images are not shown in photostructure. For me this is not the case, all media are shown in the program, but only a certain amount of the pictures are copied … maybe I have misunderstood the faq article.

So there are some files that are being copied into your library?

If you open the settings page, the “Yes, please copy my photos and videos into my PhotoStructure Library” is selected?

What’s the current copyAssetsToLibrary system setting set to?

If these seem correct, then the next step is to set your log level to debug, then in PhotoStructure, click the nav menu, select “rebuild”, and when it’s done, if it still hasn’t copied stuff as expected, you can email me the logfiles. Details are here:

Yes, nearly 8000 images are copied out of 33.000 in the source folder.

Yes and copyAssetsToLibrary = true


Can you discern any common attributes for the files that aren’t getting copied over that you’ve noticed?

(I haven’t had this particular issue reported before, so I’m keen on finding out what’s going on here).

I just sent you the log files via DM.
What I have noticed, that nearly no older images from 2001 to 2010 are imported, only 329 files from this period where imported versus 12733 files in the source folder.

I will do a fresh import again, maybe the issue is solved then.

Do those photos have the camera make/model saved in the EXIF tags? That one bit me on older photos that had either been scanned or taken with a digital camera that didn’t write camera data to the EXIF tags.

Just checked some of the pictures, the exif information are present.

Maybe some important information is missing?
Here is an example:

Filename - DCP_5787.JPG
Orientation - Top left
XResolution - 230
YResolution - 230
ResolutionUnit - Inch
YCbCrPositioning - Centered
ExifOffset - 500
ExposureTime - 1/10 seconds
FNumber - 4.50
ExposureProgram - Normal program
ExifVersion - 0210
DateTimeOriginal - 2003:05:25 20:42:02
DateTimeDigitized - 2003:05:25 20:42:02
ComponentsConfiguration - YCbCr
ShutterSpeedValue - 1/11 seconds
ApertureValue - F 4.44
ExposureBiasValue - 0.00
MaxApertureValue - F 4.44
MeteringMode - Average
LightSource - Auto
Flash - Fired
FocalLength - 6.10 mm
FlashPixVersion - 0100
ColorSpace - sRGB
ExifImageWidth - 1800
ExifImageHeight - 1200
InteroperabilityOffset - 1842
ExposureIndex - 140
SensingMethod - One-chip color area sensor
FileSource - Other
SceneType - Other

Maker Note (Vendor): -

Thumbnail: -
Compression - 6 (JPG)
Orientation - Top left
XResolution - 72
YResolution - 72
ResolutionUnit - Inch
JpegIFOffset - 2146
JpegIFByteCount - 4308

Gotcha… yeah it’s not that! Let’s wait for Matthew to review the log files… he’s really good at getting to the bottom of this stuff!

Good thinking, but I had so many people get hung up by the requireMakeModel filter that I disabled it by default in v0.8.3

LOL :beers:

I’m looking through the logs now.

1 Like

OK, I have some news :slight_smile:

I reorganized and renamed all my photos into a new directory structure based on exif data without any video files, deleted the photostructure library and the %appdata% folder.
After a fresh import of the reorganized photos all of them have been copied into the library (in library are 31126 out of 32932 photos, maybe some duplicates in there).

I did a fresh import also from the original source folder before posting here but did not got all photos copied into the library. Maybe some filename or video file caused the issue? I don’t know.

1 Like

Thanks for the update. I scanned your logs for a couple minutes yesterday and didn’t really see anything amiss, but if you find any specific files that you think should be included, but aren’t, dm me the filenames and I can look at those logs again.

These tools require a server edition to be installed: if you’re ok with the terminal, you might find it helpful:

One example:
File DCP_0513.jpg was missing in the library, but was shown in photostructure program. So it was not copied, but accessible.

Can you please update this page to reflect that it’s now disabled by default? Also update the requireMakeModel info in the settings.toml file to reflect that the default is disabled now.

I’ve been struggling to figure out why my images with no camera make or model were showing up in my library until I found this post :rofl:

1 Like

Done: and as always, if you find mistakes or poorly-worded documentation, please tell me!

Yeah, you can certainly enable this setting: I do for my personal library! Just set PS_REQUIRE_MAKE_MODEL=true (and like all boolean flags, you can also set it to 1, both values work).

(The only other non-default setting I use for my personal library is PS_TAG_NAMES_FORMATTER="family/given")

Also: I just committed a change to the settings framework to support either PS_SHOUTY_CASE or camelCase in either the environment or in the settings.toml files, in an effort to make things “just work.”