Not importing files from external drive

Hi,

New user here trying to get through my initial import. I have a couple thousand files in /home/cbz/photo and lots more on an external hard drive. Photostructure picked up the files in my home directory but doesn’t want to import the files on my external hard drive.

I am using the desktop 1.0.0-beta.13 on Arch Linux.

The directories I have configured for input are:

The external drive is mounted and is picked up by Photostructure:

My library is on my NAS and is mounted at /mnt/waltrip/photo

I did notice that when Photostructure was done importing from /home/cbz/photo, it showed very briefly some (maybe all) of the other folders and said “Done.” No files were imported from any of those folders.

None of the other folders contain a nomedia file and their names do not begin with a period.

I see that the other folders do show up in the progress table in the database but they just say “Done” and the difference between the createdAt and completedAt timestamps is less than 10 milliseconds.

Any suggestions? I tried symlinking those directories inside /home/cbz/photo since that directory was getting imported but that didn’t help either. What am I missing?

Welcome to PhotoStructure, @cbz!

The easiest way to debug import issues is to use the info tool (it’s actually why I wrote it).

https://photostructure.com/server/tools/#file-information

Note that the “rejected” section must be empty in order to be eligible to be imported into your library.

Run ./photostructure info --debug <filename> to get even more information about what’s going on: if you can’t decipher what’s going on, send me the --debug output over email and I’ll take a look at what’s going on.

Isn’t info only available with the server version? I’m using desktop, as I was planning to handle my initial import on my more powerful desktop PC and install the server version later.