Performed a Rebuild and now Photostructure has lost knowledge of the bulk of my pictures

Prior to the rebuild I had ~39000 assets and now it’s telling me I only have 286.

I’m using photostructure/server:beta on Unraid. I forced an upgrade a couple of weeks ago to see if an issue with picture rotation not working had been fixed.

After the upgrade I performed a Rebuild after which PS reports only 286 assets. I did another Rebuild yesterday and the same situation continues.

The About page gives the version as 2.1.0-alpha.3. It also reports the sync status of /ps/library and /ps/source as Stale.

Any suggestions?


That is a known issue (previously reported) issue with alpha.3 - hoping it’s fixed in alpha.4! @mrm would need to confirm

Thanks for taking the time to report this! Apologies for the inconvenience.

I got a similar bug report from @adamf on DIscord a while back, but couldn’t figure out how it happened at the time.

A couple days ago I ran sync through the debugger and stepped through work queue sequence and found that it could short-circuit the primary import step (!!), which would lead to most assets being incorrectly marked as not present on the filesystem.

The next release, v2.1.0-alpha.4, should resolve this just by running sync again.

Thanks, in the meantime can I revert to a previous version? (I’m not actually sure how to do that)

Or just re-install and never run rebuild again…

Unfortunately, libraries are backward compatible but not forward compatible: Tried an alpha or beta build, and want to return to the stable version?

You can use :stable and re-create your library, or “upgrade” to :alpha (which works well on my hardware, but there are users that have seen issues with the latest :alpha, so no guarantees). Here’s my general guidance for alpha, beta, and stable: Alpha, beta, stable, and latest; What should you use?