Photostructure keeps crashing

So again the import feature did get stuck at around 5000 images. So I tried to restart the docker container and now I get this error and can’t start photostructre:

{"fatal":true,"exit":true,"status":12,"pid":25,"ppid":18,"error":"ChildService(sync).onStdout(): Error: ChildService(sync).onStdout() failed: Error: DbRequest {\"method\":\"run\",\"sql\":\"insert into `Queue` (`name`) values (?) ON CONFLICT (name) DO NOTHING\",\"bindings\":[\"assetUpdates:3:file:///\"]}: SqliteError: code SQLITE_READONLY: at…"}

Shutting down PhotoStructure...
PhotoStructure library db has been backed up to /ps/library/.photostructure/models/backup.

hmm I’m not sure what the problem was but I restored a backup (2 days old) and only restored the .photostructure/models/ folder and that worked

I’m glad it’s working, but the Queue table actually lives in secondary stats db that sync uses to keep track of what files and directories it’s visited, and which need to be synced still…

I haven’t seen any reports from the stats db failing. Is your home directory on an automap from a remote disk?

What do you mean by automap?
The appdata gets stored on a fast ssd, while all the images come from one HDD disk.

Maybe my backup did mess with the db. I didn’t stop the docker container while I made a complete backup of the appdata folder…

arg still not working… after stopping the docker container and restarting it I can’t start it again:

Error: ModelDbJanitor(/ps/library/.photostructure) {"from":"ModelDbJanitor.setup"}: TypeError: Cannot read property 'error' of undefined¹⁶

TypeError: Cannot read property 'error' of undefined

at y.throw (/ps/app/bin/main.js:9:344491)
at L._nativeCopyFile_ (/ps/app/bin/main.js:9:198900)
at processTicksAndRejections (node:internal/process/task_queues:96:5)
at async /ps/app/bin/main.js:9:196285
at async m.time (/ps/app/bin/main.js:9:113596)
{"fatal":true,"exit":true,"status":14,"pid":25,"ppid":18,"error":"main setup failed: Error: ModelDbJanitor(/ps/library/.photostructure) {\"from\":\"ModelDbJanitor.setup\"}: TypeError: Cannot read property 'error' of undefined¹⁶"}

EDIT: Somehow stopping or restarting the container while PS is scanning the library is a bad thing…

I’ll check later today, but if nativeCopyFile is throwing errors, it may be a file permission issue. That error codepath needs tidying up, in any event.

Sorry for the hassle!

no problem. Since I do daily backups it easy to restore it and get it working again.