Photostructure won't start, just exits with "Done" after building

Expected Behavior

Photostructure should start when I run :smiley:

Current Behavior

Looks like it built, installed some dependencies, then exited:

~/photostructure-for-servers$ ./
No local changes to save
Already up to date.
yarn install v1.22.19
[1/4] Resolving packages...
[2/4] Fetching packages...
[3/4] Linking dependencies...
[4/4] Building fresh packages...
Done in 10.61s.

Shorter if I try again:

$ ./
No local changes to save
Already up to date.
yarn install v1.22.19
[1/4] Resolving packages...
success Already up-to-date.
Done in 0.67s.
$ echo $?

Steps to Reproduce

I’ve been following the Photostructure for Node instructions. I had tried the Docker route at first, but that didn’t work (don’t remember the details, but I might go try again).
While trying to install Node, I ran into this hiccup (had to manually apt remove libnode72 ).

I’m running Ubuntu 22.04.2, on a fairly old Dell Optiplex (old enough to have a Core2 6300 processor). The Photostructure for Servers page says the Docker install needs

some recent CPU extensions (like SSE3 and SIMD ). If you have one of these older CPUs, use PhotoStructure for Node."

I suspected that’s why Docker didn’t work for me, and why I’m trying Node. But I do see ssse3 in the list of flags in /proc/cpuinfo

$ grep flags /proc/cpuinfo
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts nopl cpuid aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm pti dtherm

Found this helpful page on how to get debug logs, but … setting PS_LOG_LEVEL=info didn’t get me any extra output (also tried PS_LOG_LEVEL=debug). Don’t see any other logs either :frowning:

$ ls ~/.config/PhotoStructure/

$ ls -l start.log
-rw-rw-r-- 1 photostructure photostructure 0 Jul 13 22:41 start.log


Operating system and version: Ubuntu 20.04 LTS

PhotoStructure edition: PhotoStructure for Node

Howdy, and welcome to PhotoStructure, @larcher !

  1. Make sure you’re using a reasonably recent Node. I wouldn’t use node that comes from official Ubuntu repos: I use nvm, but nodesource will work as well:

  2. Until the next release is stable, I’d use v2.1.0-alpha.7 for docker or Linux:

cd ~/photostructure-for-servers
git checkout alpha
./ --verbose

Note that you don’t normally want to run with --verbose–it’s very verbose, and (hopefully) only needed to sleuth out what’s currently amiss, but I suspect it’s due to running an ancient version of Node.