Problem getting started with Windows/UnRAID


I’m one of the guys who is trying to jump ship from Google Photos and photostructure is the first software that I’m trying out. However, until now, I’m just extremely frustrated as nothing seems to be working.

I have

  • ~ 300GB photos stored on my Unraid NAS and ~310GB photos stored on my Windows 10 desktop machine of which probably ~290GB are identical to the stuff on the NAS
  • Then there is around 200GB of Google Photo Takeout material that I also have on my Windows 10 Desktop
  • I do have a manual structure for most of my photos that I would like to keep, but I’m ok if future photos are grouped automatically by date

I thought the best way to try out the software would be to install it on Windows 10 first, get the library imported and then if I like it, switch it to my Unraid NAS. I installed according to the instructions, created an SMB share on my Unraid NAS containing my manually sorted photo library, mounted it to Windows as X:\ and set this up as my photostructure library folder. It contains a folder “manual” with my manually sorted stuff. Then I added my local Windows 10 photo folders and the Google Photo folders and hit start. I waited a couple of hours, nothing happened. Task manager showed that everything was idle. I tried out different settings, cleared all the automatically created stuff and thought, I’d start over directly on Unraid.

I set-up the official Docker container as instructed - mounted /ps/library to my /mnt/user/photos share (which contains the .uuid folder and a manual folder with my 300GB pictures). The other mountpoints are also setup to point to my cache SSD drive. I hit launch again - but again, it seems to be stuck and everything is on idle.

I thought photostructure would scan the library folder and discover my “manual” folder with all my 300GB photos? The UI only says “/ps/library Processing” and when you expand it “Scanning /ps/library”.

I increased the log level to DEBUG but the sync log files don’t tell me a lot - I attached them to this thread.

If I can’t get it to work at all soon, I’ll probably have to cancel my subscription again, luckily it is still in trial…

Any help is appreciated :slight_smile: !

Can you give us a screenshot of the docker container setup in Unraid?

Howdy, @schneida . Welcome to PhotoStructure, and apologies that your first impression wasn’t smooth!

OK: know that PhotoStructure won’t move files already found in your library directory (/ps/library on Docker), so I’d make whatever directory you think is your “best one” be the library directory, and add the other ~300GB folder be an external path in the scanPaths setting (which is set in the “Where else are your photos and videos?” settings section).

If you want to re-launch the windows version with debug logging enabled, I can take a look at what’s going on.

Know that Windows Defender is the only supported antivirus solution: most others cause PhotoStructure to throw timeouts or simply get “stuck” trying to do basic file operations.

Is this on your windows box, or on your UnRAID box?

Know that the spants template in Community Applications has some issues. I’m working with spants to get his template updated, but until then, you can add to your Docker Containers template repositories and install PhotoStructure via the template there.

UPDATE: I got my template added “officially” to Community Applications!

Also: if this is running on your UnRAID box against a local filesystem, you can skip a bunch of code that may be causing grief by setting the environment variable PS_FORCE_LOCAL_DB_REPLICA to false (read more here)

Good luck!

Sorry for the late reply - I thought I had it figured out, but it seems I haven’t.

So after @mrm asked if I could re-launch on windows with debug log, I tried exactly that. However, I made some modifications to my config - namely I enabled

scanLibraryFirst = true

Instantly, when I started the scanning process this time, it seemed to work fine. The other thing I did was restart my Windows machine after quite a while and it installed a lot of updates (I think it did one of those major upgrade, because Edge was my standard browser afterwards again…). Maybe that’s what helped.

So I kept it running basically since I 3 days and it gradually scanned my library and generated preview images and so on. Yesterday when I went to bed, it said like 8 hours remaining and I was like hey - finally. But today, I woke up and apparently Windows decided to install another Update and force restart my PC. And now all progress seems to be lost, at least once I start photostructure, it seems as if it is starting again, generating previews and scanning for pictures.

Is that normal - does photostructure not periodically save the progress it has made so that it can resume operation in the event that something goes wrong?

Anyway, I think I need to try with a smaller library first so that I can actually try out the software itself before I get even more involved…

Regarding my unraid setup - I didn’t use the template because a lot of people were reporting issues all around here and on the unraid forum. Instead I just used the official “server” container:

I can’t help with the windows setup, but regarding Unraid, you really want your library path to be in your appdata share. It’s slightly confusing, but in Photostructure, “library” means the database that holds all of the information about your photos, not where your photos are stored.

So, if you want to give Unraid another shot, you should update your library path to /mnt/user/appdata/photostructure/library/. Then, you need to add another host path for your photos. Call the container path /photos/ and then map it to your /mnt/user/photos/.

Finally, if you want to turn on “automatic organization”, you’ll want another path where Photostructure can store your organized library on your array. This could even be /mnt/user/photos/organized/. To do this, you need to set an environment variable that I can’t remember off the top of my head (but I’ll edit this post once I find it).

Hope this helps!

edit: There’s a description of how the auto-organized files are stored using the originalsDir setting: Docker on UNRAID hard crash - #17 by mrm

1 Like

Ugh, apologies again for the struggle!

Actually, I just rewrote the template and Squid accepted it: the community applications version is now the “official” template.

It seems that, at least on Windows, that the database wasn’t closed down properly for you, and on restart, something decided to open with a new DB. If you’ve got logs from around that restart, I can track down what led to the erroneous restart from scratch.

PhotoStructure does takes regular backups of the database, but the DB needs to stay in perfect sync with your previews directory, so even if you have a backup of the DB, you really need a snapshot of the previews as well.

1 Like

Well, it always holds your DB and previews.

It can hold originals, and your “automatically organized” files, as well . See PhotoStructure | What is a “PhotoStructure library”? and PhotoStructure | Automatic library organization

It can, but it really shouldn’t, at least in a typical Unraid setup. You want your database and configuration in the appdata share where you (presumably) have a fast SSD with not a ton of space, and your photo files on the array where you have lots of space.

Ah, gotcha. I wanted to keep things simple just to minimize moving parts, but in case you want to try that out, I wrote this up: Hybrid PhotoStructure libraries

@mrm I sent you the logs with DM - unfortunately no DEBUG so probably not as helpful… I still got around 18GB of previews know, but I guess those are useless without the DB either and I better start from scratch again?

@tkohhh thanks for the suggestion of splitting the library folder to have the previews on the SSD. I’ll look into that next and try unraid again. That’s on a battery backup and there is no Windows Updates mechanism that screws everything up…

Just an update - I’ve now started using the official Unraid Container and followed the guidelines for the Hybrid setup. At first, it just displayed a message about an empty library and did essentially nothing (like the first time I set it up). Then I added PS_LOG_LEVEL on DEBUG and restarted the container and right away it started scanning and adding previews. I removed PS_LOG_LEVEL again and it keeps processing images for now. Let’s see how far it gets this time :wink:

Feeling better having it on the NAS already though! Thanks so far for the support!