Processing assets not attributing folder tags after upgrade to 2.1.0a3

Expected Behavior

Assets can be sorted by When/Folder/Filetype… etc

Current Behavior

Assets are being tagged with camera, file type, dates, but folder directory tags stopped being attributed to the assets after upgrade to 2.1.0alpha3 docker. (was previously on stable)

Steps to Reproduce

  1. Installed Photostructure stable docker version on unRAID
  2. Begin to do initial sync (110,000+ photos)
  3. Assets were tagged with proper folder locations on stable version
  4. After I got to about 1500 assets sync’d tagged, I stopped container and upgraded to 2.1.0a3
  5. The sync picked up where it left off, but it no longer tags the folder locations
  6. I currently have about 17,000 assets processed (with 2+ days to go in progress bar) these are all under the “When” section, but the “Folder” section only has 1500 assets, which is about how far along processing was on the stable container before I upgraded.


Operating system and version:
unRAID 6.10.2
PhotoStructure edition:
2.1.0.alpha.3 (was on stable previously)

Thanks for reporting! I’ll get this fixed as soon as I can.

Started over with 2.1.0alpha.7 and still get 0 assets with folder attributes. I really like the view by folder aspect as all my stuff is organized before it gets to photostructure. This worked flawless in 1.x

I had some problems reproducing this, can you send me details about your host OS and computer? If possible, info or debug logs may help as well.

Hmmm… I partly figured it out. I’m using docker on unRAID. I had my source photo volume mounted as read only. Just read your info on .uuid and figured that is the problem. I mounted as RW and started so that it could write a .uuid file. Stopped the sync, shutdown and re-mounted as RO and started up again. The sync won’t restart. I thought once it had the .uuid file, it would be good to go.

I don’t really need portability and this will be the only volume mounted. I tried adding the environmental variable too but sync still won’t start again.

I think I’m good now. It didn’t like when I stopped, changed volume from RW to RO after generating the .uuid file. This time, I initial container started over, I had a .uuid file already existing on the volume and importing seems to be working as expected so far. Woohoo!