V1.0.0-alpha.1 is out! Alpha testers: assemble

I can see one CPU spiking to 100% every now and then but mostly the system is idling.

1 Like

Your system LGTM (I love my 3900x!).

OK, let me get my mac and windows 1.0.0 build uploaded, and then I’ll take a look at that. Is your library on a local volume? How many assets are in your library?

Yes, I am on 20.04 LTS:

#lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04.2 LTS
Release: 20.04
Codename: focal

Strange, why it thinks that libraw v 0.19.5 is the latest? 0.20 is the latest according to Download | LibRaw. I guess 0.19.5 is the latest here: UbuntuUpdates - Package Search (all versions of libraw)

#apt install libraw-bin
Reading package lists… Done
Building dependency tree
Reading state information… Done
libraw-bin is already the newest version (0.19.5-1ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

And PS still fails to start. :(( I am investigating why. I don’t need urgent support on this. I’ll post when I have more information or resolution.

Yep, assets are local.

I just went to check the asset count and it crashed in the last 20 mins or so, the docker is down. Last entry in the logs…

{“ts”:1615832178825,“l”:“info”,“ctx”:“TagSql”,“msg”:“updateTagCounts()”,“meta”:{“newMax”:244587,“lastMax”:244587}}
{“ts”:1615832178825,“l”:“info”,“ctx”:“DbBackup(/ps/tmp/local-db/models/db.sqlite3)”,“msg”:“backup(): starting backup to /ps/tmp/local-db/models/backup/db.sqlite3”}
{“ts”:1615832178826,“l”:“info”,“ctx”:“mkdb(/ps/tmp/local-db/models/db.sqlite3)”,“msg”:“Dynamically setting dbCacheSize to 192”,“meta”:{“dbFileSize”:141672448}}
{“ts”:1615832178827,“l”:“error”,“ctx”:“DbBackup(/ps/tmp/local-db/models/db.sqlite3)”,“msg”:“Error: Could not back up db /ps/tmp/local-db/models/db.sqlite3 → /ps/tmp/local-db/models/backup/db.sqlite3: SqliteError: code SQLITE_CORRUPT: database disk image is malformed¹▒.▒\nSqliteError: database disk image is malform
ed\n at Database.pragma (/ps/app/node_modules/better-sqlite3/lib/pragma.js:14:16)\n at /db/MkDb.ts:118:10\n at ff (/db/DbRetries.ts:41:14)\n at zB (/db/MkDb.ts:116:3)\n at Vm (/db/MkDb.ts:39:10)”,“meta”:{“from”:“DbBackup._backup() failed”,“srcDb”:"/ps/tmp/local-db/models/db.sqlite3"}}

I actually need the latest and greatest version of libraw. I’m going to have to include the binaries into the docker and node builds to get the new .cr3 support.

SQLite DB corruption is no good. Are you using PS_FORCE_OPEN?

No, not using that or any other parameters.

Where would you like other V1.0.0-alpha.1 bug reports?

In this chain or create a new thread?

This is just a display glitch - In the folders display I’m getting two “/” characters - it all works fine. Its probably a mapping with docker, but not sure.

Screen Shot 2021-03-15 at 15.13.17

I’m happy to reply here or via new topics.

That’s the mount point’s name, or “authority” for the file URI. I actually did the slash-prefix on purpose, to show that it was the root-mounted directory, but given that its parent is “Folder” I think it can go, and I certainly see how it looks wonky. I’ll fix it now.

1 Like

Same here on Debian Buster, but it seems that PS searches in the wrong path. A quick

ln -s /usr/lib/libraw/dcraw_emu /usr/bin/dcraw_emu

solved it for me :man_shrugging:

1 Like

@matmo fantastic! Thank you. Works here as well.

Yeah, the libraw-bin package adds binaries but not to the PATH. I’ve updated the default PS_TOOLS_PATH to include /usr/lib/libraw so you’ll be able to remove that symlink once v1.0.0-alpha.2 is released (which may be today).

I can see one CPU spiking to 100% every now and then but mostly the system is idling.

I’m on unRaid also (with docker install) and see the same thing… very occasional use of CPU, but mostly not. It’s chewing away, and it may be I/O bound, will have to look more.

I suspect something is amiss. Even when I’m importing from my ancient slow NAS, it can keep 6-8 CPUs busy during an import. Can either of you send me debug logs?

Odd, I just uninstalled 0.6, and tried to install the alpha. On launch it just sits at the animated introduction screen and never opens. Win 10 edition. I looked for log files and didn’t see any. What should I collect?

Sorry about that: Windows and Mac desktop builds are currently broken. Apple changed signing processes (again) and I need to figure out what steps I need to do differently in their code signing dance, and my Windows build machine (which isn’t a VM) decided that it only needed to include some partial set of files into the build target. I nuked and paved windows yesterday, and that fixed the compilation issue, but something else is going on as well. That’s today’s task.

No problem, I thought I’d offer to provide debugging data. I’ll reinstall after you release a new one.

1 Like

I’m getting this error again after updating to alpha.2:

{"fatal":true,"exit":true,"status":12,"pid":13,"ppid":6,"error":"Library.setup() failed¹: Error: Library is already opened by ba2e439a7c03 (main:13) (library setup)¹⁶²"}

I do have the --stop-timeout argument, so I’m not sure what’s going on…

Does it have the same issue with -alpha.2?

Sorry, I meant alpha.2… I’ll edit my post!