Can't Launch Latest PhotoStructure Alpha

Hi there,

I just subscribed and am excited to use PhotoStructure, but I can’t get it to launch - it just hangs on the loading splash screen.

So the question becomes, what do I do here? I tried launching in Terminal and got some error messages, but I really don’t know how to handle them…

mediaserver@mediaserver:~/PhotoStructure$ ./PhotoStructure-1.0.0-alpha.7-x86_64.AppImage
libva error: /usr/lib/x86_64-linux-gnu/dri/ init failed
(node:221721) UnhandledPromiseRejectionWarning: Error: 
Something went wrong installing the "sharp" module cannot open shared object file: No such file or directory

- Remove the "node_modules/sharp" directory then run
  "npm install --ignore-scripts=false --verbose sharp" and look for errors
- Consult the installation documentation at
- Search for this error at

    at Object.<anonymous> (/tmp/.mount_PhotoSgVoG4I/resources/app.asar/node_modules/sharp/lib/constructor.js:32:9)
    at Module._compile (internal/modules/cjs/loader.js:1078:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1108:10)
    at Module.load (internal/modules/cjs/loader.js:935:32)
    at Module._load (internal/modules/cjs/loader.js:776:14)
    at Function.f._load (electron/js2c/asar_bundle.js:5:12684)
    at Module.require (internal/modules/cjs/loader.js:959:19)
    at require (internal/modules/cjs/helpers.js:88:18)
    at Object.<anonymous> (/tmp/.mount_PhotoSgVoG4I/resources/app.asar/node_modules/sharp/lib/index.js:3:15)
    at Module._compile (internal/modules/cjs/loader.js:1078:30)
(Use `photostructure --trace-warnings ...` to show where the warning was created)
(node:221721) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see (rejection id: 1)
(node:221721) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

Any advice is appreciated. Thanks!

Not sure if it’s related, I’m using PhotoStructure for desktops. But when I upgraded to Alpha I got the same thing - stuck on loading splash screen. I tried waiting a few hours, didn’t change anything. I ended up rebooting and then it worked. YMMV.

Well you got me all excited, but unfortunately rebooting didn’t work for me.

Howdy @tmeitner and welcome to PhotoStructure! Thanks for taking the time to report this.

PhotoStructure should be statically compiled, but it looks like the alpha.7 build linked to the system library instead.

Assuming you’re on Ubuntu 20.04 or later, if you run

sudo apt install libvips42

and then try again, it should launch. If it doesn’t, please tell me!

I’ll fix this in the next build. Apologies for the hassle!

@Rodger you’re on Windows 10, correct? That’s frustrating that you had to reboot to make it go: sorry about that.

What anti-virus/anti-malware are you running? The built-in Windows Defender, or something else?

That worked like a charm! Thanks so much for the fast support! I love seeing what is happening with PhotoStructure as I think it’s the perfect solution to my Google Photos problems. Looking forward to diving in. Thanks again!

Yes I’m on Windows 10. Yes just built-in Windows Defender is the only software running.

I do have a pi-hole on the network, and also Cisco AMP running on a Meraki security appliance (info about AMP here). And there’s the usual browser add-ons like uBlock Origin.

Extra information: when I upgraded to Alpha, I also added another 3,000 pictures into my library. So that’s why I gave it a few hours before trying to reboot. But, since the disk utilization was 0% I figured there was no point in waiting longer.

I have a pi-hole as well ( :+1: :+1:), but neither the pihole or your AMP/firewall/router should get in the way of just launching PhotoStructure.

If I had to guess, if a reboot fixed it, the problem was that your Windows box had an unhealthy network share. I turn off my NAS at night, and sometimes my Windows test boxes just can’t seem to recover until I reboot.

Please ping me if you see this again (or anything else odd or confusing or buggy)!

I only have 1 network share, and it’s been offline for a few weeks. (Before I ever started using photostructure). I have to drive far away to get that network share back online. :slight_smile:

I have never referenced that drive letter in photostructure, do you still think it would have any affect on getting stuck at the loading screen?

Unfortunately, yes!

PhotoStructure scans all volumes in order to be able to convert between the library URIs and actual native pathnames:

The issue that I’ve seen on my windows test boxes is that there seems to be different levels of “disconnected” or “unhealthy” remote mountpoints. Even with timeouts, Windows applet calls (like fsinfo drives, Get-PSDrive -PSProvider FileSystem or Get-WmiObject Win32_NetworkConnection) can sometimes get stuck (and even wedge other subsequent filesystem calls) when there are drives that are in a bad-enough state.