Confused about video. Still can't seem to get them to show up

3 Problems.

  1. I removed all of the photos from /ps/library (i.e. /Volumes/Photos/ on my mac) and they still show up even after syncing. It appears that they don’t automatically delete.

  2. The Asset count in the UI doesn’t seem to be right.

  3. I’m still not seeing video files in the UI.

I currently have 2 JPG and 2 *.MOV files in my /ps/library folder. If I run the re-sync it shows some sort of encoding message at the top, but the videos never show up.

I’ve also run a verbose force sync in the console and it appears to complete, but again, nothing in the library to see for that video.

If they don’t have any private content, could you email either .MOV to I’ll see if I can reproduce the issue.

Hmm…I can get them to you, but just to test something out, I used Handbrake to encode one of them (they’re *.mov files from my iPhone 13 Pro Max) into MP4 format. It worked. However, it took 30 minutes to transcode.

Is there a setting on my iPhone that can put the files into a format that keeps me from needing to do this?

Ah! I didn’t realize the videos might be enormous. I bet the transcode operation is getting timed out, so the asset fails to import.

If you don’t need it transcoded, you can tell PhotoStructure not to bother. There are three settings you can pay with:

I’d use either the first or last one.

You can see these tag values with exiftool:

exiftool -VideoCodec -CompressorID -CompressorName -mimetype /path/to/

Hmmm…well, I have a bigger problem currently. If I have a video that is being transcoded properly, while the transcode process is under way, it eats up nearly all of my entire Unraid CPU, killing every VM and Docker container I have running.

If I exclude certain codecs from being transcoded, do they not then show up in the library? Are they bypassed completely?

I assumed (and it might be a bad assumption) that if ffmpeg can’t transcode the video, it’s corrupt, and shouldn’t be imported, so it’s not added to your library.

If you set your settings to not transcode, the videos should only need to have a screen grab for the thumbnail, and the file will import successfully.

If you need help with these settings, holler.


So I have been having a similar issue. Not sure if I should start my own thread or not or just add to this one. I am running Photostructure on MacOS on Apple Silicon. Not the node or server version. I think my first issue was the file size limitation for importing videos so I changed that setting (in the .toml file) to about 15gb as that was around my highest amount home movies. I then set it to rebuild my library and let it run for two days. It seems to have imported some, but only the 4gbish ones. There are others that were not imported.

Since then I have went back into the settings.toml file and turned off video transcoding. I did a resync of the library but nothing new has shown up. Do I need to do a full rebuild to re-import new ones that it has previously skipped for some unknown reason? I would love to just point it to the folders holding all the video files and have it try and import any that are not in PhotoStructure. Having to rebuild the entire library seems like a waste of resources, not to mention time.

Thank you,

You should only need to run a “sync”, but due to a caching bug in v1.1, that won’t work until v2.x is available.

Completely agreed: in the near future, just running sync (via the cli or via the nav menu) should suffice.

I’ll also be adding filesystem watching, and drag-and-drop support for folder syncing soon, which should also help make this less painful.

Thanks for sharing your feedback!

Thanks for the reply. I might wait for the next build then to ensure everything is imported correctly. Is there an ETA for release by any chance?

Soon: there’s a job queuing issue that I found, that I have a breaking test for, so as soon as that’s addressed, I believe I can push an alpha build.

I’ve gotten smaller, MP4 videos to work perfectly fine, so I’m probably just going to be intentional about the videos I want to be included and just upload or copy finished MP4 edits into the library so I’m not muddling up the entire system with bazillions of video bytes.