V1.0.0-beta.14 released

What’s in it?

Bugfixes and stability improvements:

  • :bug: PhotoStructure could fail to launch on case-insensitive filesystems due to userdir merging code. Thanks for the report, awojtas and bjarte!

  • :bug: Cleanup jobs (like removing old logfiles, image caches, and readdir caches) are properly scheduled now. Thanks for the bug report, bdillahu!

  • :bug: opened-by lockfiles from prior versions are automatically cleaned up (to avoid these errors).

  • :bug: Library write tests were run more often in beta.13, but any network fileshare hiccups could cause PhotoStructure to shut down. We now only run the write test once, at startup, only on the main process. Thanks for the reports, tkohh and awojtas.

  • :bug: Cross-volume database backups could fail, causing PhotoStructure to shut down after several hours. This was from beta.13 switching from fs-extra.move() to fs.rename(), and was reverted in beta.14.

  • :package:/:bug: Is your library stored on a remote volume? The new maxSyncFileJobsWhenRemote (which defaults to 2) should avoid overwhelming the I/O on slower NASes, which can cause sync to crash (especially when PhotoStructure is running on high-core-count servers). See this post for more details. Thanks for the idea, Mike!

  • :package: Added movflags +faststart to the default ffmpegTranscodeArgs. Thanks for the suggestion, Zirro!

How do I install it?


Any unfinished issues?

Déjà vu from beta.13, unfortunately (I wanted to release the launch-crash bugfix out asap):

Where should I report bugs?

Reply here, or create a new bug, or post to the discord: whatever is more convenient for you.


So far so good! -

  • Long delay when starting - gone
  • Test library which wasn’t starting on b13 is now starting

thank you! I was about to report the cannot write problem but you already have fixed it!

On Windows 10 Desktop I checked for upgrades and download started automatically as reported by a notification. I then got a notification that there was a problem. I tried to catch the notification but missed it.

I checked for upgrade again and the file was downloaded and upgrade started. Admin permission was requested and granted. The program did not automatically start. I did wait 2 minutes and started the program manually.

Updated! Looking forward to confirming that the crashing problem is gone so I can get back to testing syncing new files!

Thanks, as always, for all of your excellent work!!!

UGH DARN. I’m hoping that the shenanigans from the beta-13 launch crash may have borked things? I don’t really have any other tricks up my sleeve for that issue. :persevere: