Your library at * is missing. You can either

I use my Photostructure license on mac and windows laptops. While trying to work with my new external SSD drive I experienced the error reported here on the mac: Missing library, but “Pick a new library” doesn’t work - Bug - PhotoStructure Forum

But on my Windows laptop the error is similar:

Your library at * is missing. You can either:

  1. Mount or turn on that drive, then click “Try again”, or
  2. Pick a different directory by clicking “Pick a new library”, or
  3. Give up for now by clicking “Quit”.

The mac fix you shared works; what is the fix on Windows?

*Note: I have not used either system with photostructure in some months. I’m starting a new project so I want to create a new photostructure library on external media

I tried using the Uninstaller to remove Photostructure on Windows. I also checked each user account to make sure there wasn’t another instance of the app running.

Unfortunately, when I reinstall photostructure using the 1.1.0 installer, it drops me into the “missing” library message I posted, and all I can do is “Quit”

Apologies for that bug! I fixed it in the last v2.1 alpha build.

I don’t have the uninstaller delete the PhotoStructure system configuration directory (%APPDATA%/PhotoStructure on Windows) on the off-chance that the user spent time editing their system settings.toml.

If you want to change your library directory, you can either:

  1. Normally you should be able to edit the library directory on the settings page (via the main nav menu or tap alt and open the Settings page via the menubar). I suspect this may not work for you due to the aforementioned bug, though, so do one of these alternatives:

  2. Shut down PhotoStructure, delete the system config directory, and restart

  3. Shut down PhotoStructure, set the PS_LIBRARY_DIR environment variable to the new directory, and restart.